Cannot install rocket plugin!


First I am new to mac’s. I run logic 8 with a MBP.

I cannot install the evaluation version of Rocket plug.
I download the AU version. But I am curious about this, because I should install it in the Librady-Audio-Plugins-Components, and my Mac has 2 places for this.

One is Macintosh HD–Library–Audio–Plugins–Components
and the other is Macintosh HD–Users-Myname–Library–Audio–Plugins–Components

Why do they both exist? Each Plugins folder is different from the other and I did put the Component file on both of these folders and Logic didn’t recognize them.

What am I doing wrong?


There are two different directories because if you’re not an administrator user on the Mac, you can’t put files in /Library/Audio/Plug-ins/Components. Plugins in that directory are available to host programs no matter who’s logged in, though. If you put them in Your Home Directory/Library/Audio/Plug-ins/Components, they’re only available if you are logged in…if someone else logs in, those plugins aren’t available.

The two directories are standard Mac OS X locations…has nothing to do with The Rocket in particular.

You should only place the plugin in ONE of the locations, preferably NOT the user directory.

Remove one of the copies and make sure that there is only one…then clear Logic’s plugin information cache and re-try. I’ve used the plugs in Logic 8 and know that they work.



OK thanks for the reply.

I did put the RocketAU.component file in the mbp’s library–audio–plugins–components folder, but logic cannot recognize it.

I deleted the component file from my own library as you told me, and did reset and rescan logic for au plugins.

Anything you can suggest?


I just installed the same way some other au plugins and worked OK.

Logic doesnt recognize stillwell plugins

I am on a late 08 macbook pro, leopard 10.5.6

I am running Logic Express 8.0.2 here on a Mac Mini running Leopard 10.5.5…no problems.

I have a full copy of Logic here but have to attach another hard drive to be able to install it…not enough disk space. There should be no significant difference in the audio engine and plugin handling between Logic and Logic Express, however. I know that other users are using Logic 8 and my plugins with no issues…Try deleting ALL stillwell plugins from everywhere on your hard drive and then rescan your plugins. Then, go download a fresh copy of ONE of my plugins and try it.

I’ll try and scrounge up another hard drive to install Logic on and test here myself.


EDIT Well, scratch that…you can’t install Logic on anything but the system volume. Bummer.

I tried installing Bitter plugin from Schwa. Works OK.
The Schwa SchOPE plugin is recognized, but Logic won’t load it. I get an error message “fail to load AU plugin, contact manufacturer to get an updated version”.
The Schwa spectro works fine.

Then tried Transient Monster. Nothing.

Maybe its the new leopard version 10.5.6 that causes the problem

By the way, 10.5.6 addresses these problems:

  • Core Audio and AU component version mismatch fix
  • Multiple instances of MatrixReverb in separate threads fix
  • Core Audio compressor threshold fix
  • Switching default audio device’s output stream is now immediate
  • More channels for Core Audio 3D mixer
  • Programmatically created (public) aggregate device now plays correctly
  • Audio Channel Layouts and Unique ID fix
  • Changing the composition of an aggregate device audio dropout fix
  • kAudioSubDevicePropertyDriftCompensation property can now be set on an aggregate device
  • Renaming aggregate devices now propagate device name changes to all applications
  • AudioFileOpenURL memory management fix
  • CoreAudio AudioFileWritePackets file creation fix
  • audioqueue compatibility fixes
  • audio file stream compatibility fixes
  • ExtAudioFileCreateNew memory management fix
  • ADTS files now supports kAudioFilePropertyPacketSizeUpperBound
  • Core Audio performance fixes

Okay, I took a deep breath, updated my Mac to 10.5.6, went into the AU Manager in Logic Express and told it to reset and validate my plugins and…

Nothing. No problem at all. Every plugin revalidated and enabled itself.

Are you sure that you’re uncompressing the AUs when you download them? On the stillwell plugins, when you go into the AU Manager, what version does it say my plugins are? Mine are currently 1.52.3.

I’d like to help you out here, but if I can’t reproduce the problem, it’s REALLY tough to fix…


My AU manager doesn’t list the stillwell plugins.
Only schwa, apple, and others from voxengo, flux etc are shown.
Well what can I say, it simply won’t work!

If it doesn’t list them, you either don’t have them in the right folder, they are still compressed in zip format, or the downloaded copy you have is corrupt.

Please do what I asked earlier…delete ALL stillwell plugins from everywhere on your hard drive, then launch Logic and rescan all AU plugins. Quit Logic. Download a NEW copy of one of our plugins, and be sure that it has unzipped itself when downloaded. Copy the component to /Library/Audio/Plug-ins/Components. Re-launch Logic…it should scan and find the plugin. Beyond that, I don’t know what to tell you…it is confirmed working, but I agree that it is not working FOR YOU.

Logic occasionally has problems with its AU component cache. Try trashing the caches…see these Apple support threads for more detail. … 5&tstart=9 … 3&#6247833


I did the steps you told me, nothing happened.
I trashed the AU component cache, then logic rescaned all the plugins but found no stillwell plugin.

I am pretty sure I have unzipped and put in the right folder, because every other plugins I have installed are shown correctly.

Would you mind sending me a component file of one of your plugins? So I can place is directly in the components folder and make sure that its not because its an unzipping or corrupt file problem.

Maybe its because my unzipping programm doesn’t do the job well? Or corrupt file?
If you send me a clean component file, maybe we can sort things out

It has to be compressed/zipped, unfortunately. A component (or any other Mac app, for that matter) isn’t really just a single file…it’s a “bundle”, which is a special kind of directory with specific folders and files inside it. If I unzip it and put it on the web server it’ll be a directory full of junk that you’d never get downloaded and reassembled correctly.

What is the file size of RocketAU.component? Mine is 3.9 MB, or 4,015,140 bytes. If it’s still compressed it will be 3.0 MB or 3,105,764 bytes. If it’s anything else you’ve got a bad file and need to clear the cache on your browser and try to download it again.


My file sizes are same as yours, no difference.

I retried everything an nothing happened. What can I say…

Anyway thanks for your time and patience, I hope someday it will work!


I too am confused by this : I was just with someone who was running on (I think) pretty much exactly your system, with no troubles at all. Most odd.

I am SO SO SO PRETTY sure I am doing nothing wrong.

Maybe its my unzipping program. I use Zipeg. What do you guys use? Maybe I should try a different programm too.


These are some pictures I took of my system

DINGDINGDING! I think we have a winner. Do NOT use a 3rd-party utility. After you download the .zip file without uncompressing, use the stock Apple utilities to uncompress the plugin. I have not heard anything specific about Zipeg, but I have seen other utilities corrupt our plugins. No clue why…we use the stock Apple utilities to zip up the plugins to begin with.


This is called REVELATION!!!

THANK YOU. I am definately buying now, you where very helpful

It was the zipeg


Glad you got it sorted, sorry it took so long!