Trouble on 10.5.4

I’ve been trying out the latest build of The Rocket(says Today 2:24PM) on a MacBookPro running 10.5.4.
In Digital Performer(6.01 and 5.13) audio is muted on a stereo track when Rocket is inserted, returns when bypassed. Meters are working and moving controls seems to effect GR. On mono tracks, DP give the following message:

Digital Performer has encountered an error
Mas, 0 error reported by Mas Audio Unit Support
Failure: Initialize 213 -2147450878 [-2147450878]

The newest Major Tom build performs in the same way.
All of the other new builds seem fine in DP.
In Reaper 2.46Beta, Rocket is working though no GR meter activity.
In Amadeus 1.32, there is no change to audio though meters indicate function.
Wave Lab 1.3.3 crashed when attempting to bypass Rocket.


Okay…I’m on it. My Mac development box’ hard drive took a dump and had to be repaired restored (yay, Time Machine), but I hadn’t reinstalled DP.

I’ll sort it as quickly as I can.


Also problems here with the Rocket demo, in DP5.13, 10.5.4, Intel Mac.

Erratic performance, i.e. GR VU doesn’t work, insane level jumps when calling up a preset, etc. etc.

All other Schwa/Stillwell plugs I own work fine here (Olga, Major Tom, VibeEQ, Verbiage, BadBussMojo, all builds from May 17/18-2008) and the Tin Man demo works well, too (build from Sept 10.)

The presets are NOT level matched…some have quite large amounts of gain reduction…that much is normal, as is the twitchy gain reduction meter. Does it not move at all, or simply moves very fast?


scott digs for his DP5 disks…

Grr…doing it here on 5.13 / 10.5.4.

I’m on it…I’ll post when I find a fix. Hopefully won’t be too long.


Thanks. Let me know if a new build needs testing.

Yay…fixed. update posted to website, so just re-download it.

for the programming-inclined among you, abs() is not necessarily the same thing as fabs(). oops.

Tested on a Core 2 Duo Mac Mini, 10.5.4, DP 5.13.


I’m checking it out right now. Was the syntax error in framework shared with Major Tom? That is behaving the same way…

ooooo…you know, it might. forgot to even look at it. been kinda focused on Rocket today.

Since I moved up to 10.5, there’s a new version of the compiler…from GCC 3.3 up to GCC 4.0. It broke several other things, but I already fixed those.

I’ll check…hang in there a few minutes.


Hmmm…Major Tom is working for me, no problem at all.

Can you send me a sample DP project that demonstrates the problem? Make sure that it uses nothing but Rocket or Major Tom and stock DP effects or synths. Include any media (wave files, etc.) that are needed for the project. Zip 'em up and mail 'em to scott at stillwellaudio dot com.


Thanks for the replies.
Sorry, no love with the latest Rocket build(Today 8:59PM) on DP6.01.
Same error message on mono tracks, meter activity on stereo tracks but no audio unless bypassed.
I dumped the Audio Unit Info Cache after installing Rocket but before launching DP.
I’ll try Major Tom again and send you a project.

grr…MOTU must have changed something in DP6…figures. They are MUCH tougher to get plugs working in than anything else Mac except maybe Logic. You can get plugins to pass Apple’s own auval or aulab tests and it won’t even BEGIN to work in DP.

Guess I’m gonna have to upgrade to DP6 soon. If you still have 5.13 somewhere, see if the plugs work for you there…they are here.


Rocket and Major Tom do the same thing on DP5.13 as DP6.01, but they are installed on the same machine and I suspect 6.01 modified some shared file or libraries for AU support.
I was check Rocket Comp in AULab(2.0.0). It processed audio very nicely but AULab crashed when trying to bypass Rocket. I randomly tried Massey TapeHead and it bypassed fine, then replaced with 1973 and AULab crashed again.
Sorry to be a thorn in your side!

Hrm…they pass 10.5.4 auval, and I did load them in AULab, but I don’t think I tried bypassing them…I’ll give that a whirl. I may have to do that tomorrow, though…it’s been a looooong day.


I got the “no output on stereo tracks” issue figured out. In DP6, AU sidechaining has be implemented.
If The Rocket is inserted on a stereo track, the sidechain has to be set to that track before the plug will output audio. Voxengo Crunchessor behaves the same way, I actually stumbled upon the solution on their forum re: a problem in Logic 7.
Looks to me like MOTU’s problem, not yours…
Still can’t figure out the error on mono tracks or crashing some hosts when bypassed.