Too many 1973's crash Logic Studio???


Today I booted up Logic Studio and couldn’t get it to get past the start-up. So after much troubleshooting I found out that 1973 was hanging Logic up for some reason. (I went through and cleared out all of my third-party AU plus from their Components folder and began adding them back one by one until I got snagged on 1973.) So once I removed 1973 from the Components folder I was able to open up Logic as usual. So then I started tallying up how many instances of 1973 I had going at once in the song Logic was trying to open up at start-up. All together I had five 1973’s going, and I think four of those were using the OverSampling feature. So I decided to eliminate two of the 1973 instances and then I put the 1973 component back into the Components folder and voila all was well again and Logic loaded up as usual. (Also, I cleared out Logic’s Audio Units Components cache so that each plug-in scan was fresh and not based on older settings.)

So has anyone else run into this? Did having four 1973’s with oversampling cause Logic to choke on lack of CPU? (My '07 MacBook Pro is a 2.4 Core2Duo with 4GBs of RAM and 170GB of hard drive space available and the CPU on this song has only been reaching around 25%-40%.) Are there limitations on how many instances someone can use the Stillwell plugs in any given project?

Thanks for the help!

All the Best…


There shouldn’t be any limitation to how many instances are running other than total CPU use, no.

With oversample on and all filters engaged (if a control is at zero dB, it consumes zero CPU, and the HPF only consumes CPU when it’s on), 1973 uses about 0.8% CPU per instance on an Athlon 64 X2 4400+ (which is a 2.3 GHz dual-core processor). Usage should be pretty darned consistent across platforms, so I can’t think that that’s the problem. A C2D like you’re talking about should show even less CPU usage. I’ve run 6 or 7 instances just when tinkering around in Digital Performer 5.13 on the Mac with no problems.

Does it actually crash if you wait long enough, or does it just beachball on you? If we could get a crash report that would be useful.

I guess one of these days I’m gonna have to suck it up and buy Logic. sigh


Hey Scott…

Logic would crash in the sense that it would just hang there for several minutes and the cooling fan would kick on into high gear. It wouldn’t crash the whole Mac per say, just the program itself. So then I would “Force Quit” Logic and the little window would say that Logic was “Not Responding”. (Sounds like Windows 98 revisited. Or maybe Vista is secretly working in the background… :smiley: )

Anyhow, I looked around on my Mac for an error log for Logic but didn’t find any. Any idea where that would be located? I’d really like to help if I can. If I can figure out where to find those error reports I’d be more than happy to email or PM them to you. I did send the error reports in to Apple via the automated pop-ups so surely they are stored on the HD somewhere. I just need to know what the file names would be or where to look. Let me know if you know where to find them.

So far 1973 is working again as normal. I even bumped OSX up to 10.5.3 whenever i was troubleshooting earlier, and so far 1973 is holding steady again. What a weird day it has been…

So now back to mixing things down…

Thanks again! Great tech support by the way!

Best Regards…


BTW…can you check my forum settings? I don’t get any notifications to my email address whenever my watched threads have replies. I looked around for a bit in the user control panel but didn’t see any problems and it shows that I am supposed to receive notices automatically. I dunno… :question: Thanks!

When you get the option to send to Apple, just select all the text in the window of the dialog (click in the window and Cmd-A, Cmd-C to select all text and copy to clipboard) and paste it into an email to scott at stillwellaudio dot com.

Your settings look okay on your user account, and I get other emails from the forum software, so I’m not sure what the problem could be…


Alas, it all happened again. But at least I know how to fix it sort of. I’ll email you the two “.docs” that I made of the error reports. Thanks for the help!


Got 'em. I’ll dig a bit and see if anything comes to light. I do notice that it’s not crashing in my code anywhere in my code (which doesn’t mean it’s not a problem with the plugin, but also doesn’t mean it IS a problem with the plugin…).

Like I say, I’ll dig in and see what I can find.



I don’t know if this is related but I have found that a 1973 EQ placed immediately above an instance of Space Designer uses noticeably more CPU (including frequent spikes) than the same 2 plugins with the same settings but reversed in order. I haven’t noticed that with 1973 and other Logic plugins but I haven’t tried many combinations. Maybe what’s causing the crashes isn’t 1973 by itself but in combination with some other plugin.

I’m running Logic Studio 8.0.2 on a 2.16GHz MacBook Pro and OS X 10.5.3.



Any word on the error reports I sent you? Also, all of the Stillwell plugs seem to hit sort of ceiling within Logic as far as how many instances can be used simultaneously, either individually or collectively. The only ones that I have not tried are Verbiage and Bad Buss Mojo. Everything else seems to crash when I start using too many of them at once. I thought it was just 1973 but I guess not. (But darn it they all sound good!) Also, I am no longer having crashes at the same stage of starting Logic up…it is now crashing once everything is loaded up and the Arrange screen is in full view. But at that point I get the Rainbow Beach Ball of Death and can go no further. It just locks up until I “Force Quit” Logic. Any ideas?



I have a suggestion: Try downloading / using a number of Schwa plugins instead of mine. We both have the same underlying code base, so if it fails in his plugins too it will be either a problem in that code base or in Logic. If Schwa’s plugins work and mine don’t, then it’s a problem unique to MY code.

I’ve noticed some memory leak errors that have started appearing after a recent Mac update, so I’m thinking it might be an Apple issue…remains to be seen, though.



I tried all of the Schwa AU plugs in Logic and had 15+ instances running simultaneously. CPU on my MacBookPro (4GB Ram) was hitting roughly 75%. No Crashes or lock-ups. No rainbow beachball. Went ahead and got rid of the Schwa plugs and started throwing in Stillwell plugs and got the beachball after just nine instances (4 x 1973, 2 x Transient Monster, 1 each of Major Tom, Vibe EQ, and Event Horizon).

I’ll attach the crash reports in an email. Hope that helps…

Thanks again!