No sound, ever

Hello, am I missing something? I insert tinman as an effect, right? Like a chorus or something, right? I’m not getting any sound whatsoever, from any sound source. I tried the the threshold, the mix, everything. I’ve redownloaded and reinstalled, I’ve rebooted. I’ve tried different projects and different tracks, all nothing - no sound unless i bypass the effect.

Trying it on sonar 7 on xp.

I just tested it in Sonar 7 and it works fine … yes, it’s an effect :slight_smile:

Do you by any chance have an older PC?

how old is older?
centrino duo, a couple of years old i guess - i tried your other plugs and no problems at all.
the only other plugs i ever had a no-sound problem with have been ancient synth edit freewares.

Baffled … what buffer size are you running?

audio buffer size I/O? 256 kb

Runs fine here in Sonar 7, on XP, at 256 sample buffer.

I simply can’t imagine what the problem is.

Just to eliminate some random possibilities, would you mind emailing me a simple sonar project (cwp) demonstrating the problem? schwa at stillwellaudio dot com. Thanks.


That project plays fine here, and Tin Man does its thing.

You say that Tin Man shuts off audio completely on the track when it’s enabled? And there’s no chance that it’s simply because the mix is set all the way wet and the threshold is high? With the mix all the way dry, it should just pass audio untouched – to be clear, you’re saying that it isn’t?

Does the gui work? Can you get the keyboard to light up at all by passing sound through it?

its completely dead - nothing lights up, it stops all the sound. i’ve tried all the presets, threshold and mix all the way up and down.
it just stays a red light on the threshold

i can click on the gui and get the manual and the reminder screen, but otherwise nothing

The only thing I can think of, and it’s a total long shot and makes no sense really anyway – would you mind trying this build? … nstall.exe

tried the noSSE2 - exactly the same, no sound and no lights on … are there any settings i could experiment with? i tried a larger buffer size earlier with no luck …

Honestly, I am completely baffled … we’ve sold hundreds and hundreds of plugins, and I’ve never heard of a problem like this. It seems like we’ve ruled out the OS, buffer size, host, and user error. What else is there?

If you have any other hosts installed (or want to take a minute to download something easy to install with a free demo – Reaper, Forte, EXT2, etc), I’d be interested to know if Tin Man works there.

just tried it in reaper and it works perfectly! how annoying!

Well, that’s at least some information!

Since it does work in Sonar 7 for me (and Sonar 6 too for that matter), it must be down to a setting in Sonar, or something different between the audio driver setup in Sonar in the audio setup in Reaper. I just wish I could reproduce your problem!

what should i try changing? i tried sample rate and multiprocessor, i dont know what else i could try

i have had a problem before with a couple of synths in sonar where the notes hang on playback. apparently they werent responding right to sonar’s stop note command … any chance this could be sonar sending a permanent stop note command?

… i dont know anything about programming so thats just grasping at straws …

the other problems i’ve had with sonar seem to be related to the C++ 2005 installation

Do you have some version of Visual Studio 2005 on your machine?

under add/remove programs i’ve got visual c++ redistributable 2005, 2 versions listed and c++ 2008 - no ‘studio’

Tin Man isn’t a MIDI plugin, it’s an audio plugin, so note-off issues would not have any effect.

I don’t think the presence or absence of any VC++ library would make any difference, all of our plugins are compiled statically, meaning they are self contained and don’t depend on any other code library on your computer.

as i say, im not a programmer and dont know anything :slight_smile:

alas, the tinman just isnt working for me, in sonar … hopefully some other people turn up with the same problem and can shed some light on it