Schope 1.54 Crashes Fruity 7&8, Ableton 7&8, VST Host, etc.

Schope crashes Fruity Loops 7 & 8, Ableton Live 7.0.3, Ableton Live 8.0.4, and VST Host on Windows XP SP1 & 2. I’m able to get Schope to crash these hosts in under 15 seconds 100% of the time. It crashes so consistently that I suspect that the vst version on a Windows XP PC will crash every host on this platform. I don’t think the crash is host related.

Loosely speaking, the “cause” of the crash is the relation of the horizontal zoom sliders in the left position to the offset values in oscilloscope mode. If I move both horizonal zoom sliders all the way to the left, set input 3 to 121 ms, and then activate input 3, Ableton Live 8.0.4 crashes 100% of the time, regardless of the position of the other knobs. This method crashes Ableton in the opposite order as well. That is just one of the many ways to cause Schope to crash these hosts. Basically, if the horizontal sliders are to the left (they don’t have to be all the way to the left), moving any of the offset knobs will cause said host to crash. Again, this only happens in oscilloscope mode. I should also mention that this happens with version 1.51 as well. Here is the event viewer error report:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 9/25/2009
Time: 12:37:48 AM
User: N/A
Computer: BEAST
Faulting application live 8.0.4.exe, version, faulting module schope.dll, version, fault address 0x0000b425. For more information, see Help and Support Center at
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 6c 69 76 ure liv
0018: 65 20 38 2e 30 2e 34 2e e 8.0.4.
0020: 65 78 65 20 31 2e 30 2e exe 1.0.
0028: 30 2e 31 20 69 6e 20 73 0.1 in s
0030: 63 68 6f 70 65 2e 64 6c chope.dl
0038: 6c 20 30 2e 30 2e 30 2e l 0.0.0.
0040: 30 20 61 74 20 6f 66 66 0 at off
0048: 73 65 74 20 30 30 30 30 set 0000
0050: 62 34 32 35 0d 0a b425…

Thanks for the report. Clearly a Schope bug, I will fix posthaste.

Would you care to try the beta of Schope 1.55 at … nstall.exe to see if it fixes your problem?


I just tried the beta for 15 mins and it’s working perfectly. When I test things I intentionally try to break them; I use them in a way that one would never use them in normal usage. Since the previous versions crashed very easily, and now as much as I try to crash this beta I cannot, it’s unlikely that with any combination of settings this bug will resurface. Great work, sir! I’ll definitely be purchasing this plug in the future.

By the way, it would be great if you added vst parameters to the freeze function. It’s the only function in Schope that can’t be assigned to a midi controller through a host.


Reminds me of my problem with schope and ableton live:

Tried the new beta today but nothing changed with my issue.

Maybe it’s the time to take another look at it?

Hey Schwa …

I just bought Schope and I have the same error with the zoom sliders.I am running MAC though - is there a possible fix for this??


I think the OSX Schope might just need a new build, I should be able to fix this up tomorrow (Monday).

… I can’t reproduce this problem using the latest Schope AU v1.57, downloaded off the web site. Are you definitely using that version?

Yep … I am using 1.57 - but i downloaded the VST not the AU … Just tried the AU and I can happily report that it doesn’t break … but the VST needs to be fixed and the website still says that its at version 1.54 :wink: