Not working with Logic 9.1 (64-bit mode) with SL 10.6.2


I can use Rocket fine running Logic in 32bit mode - however when I run in 64bit mode Rocket doesn’t work. It shows up in my projects as been on and fully functional but all it does is block the audio in the chain. When I bypass the plug, audio resumes back through the chain.

I know Logic 9.1 was only released today and 64bit support is relatively new but this is the only plugin I’ve had problems with (except for BFD2 which won’t work in 64bit mode also). Most of my other plugins happily run with the 32-bit Audio Unit bridge but Rocket doesn’t like it.

It’s strange because there is no error message and it loads up, you can control the plugin, except there is no sound getting in or out of it. The meter doesn’t move either.

Just thought I’d let you know. Not sure if this is the same with all the other Stillwell plugs as this is the only one I own. Would’ve posted in the Audio Unit public beta forum but it was locked.


PS I have the latest build I downloaded yesterday from your site.

Well, actually, I just updated the betas today, so grab 'em if you want…I’m switching to an actual .dmg installer that should make it easier for the technology-challenged user. Haven’t got the nice background pictures in place yet to show that yes, you should drag THIS from HERE to THERE, but it’s a start.

Haven’t seen 9.1 yet…guess I ought to contact apple and see what they say.

The problem I have is that if I compile for 64-bit, I lose compatibility with everything below 10.6. Maybe I’ll make a separate build for that…I’ll have to see.


Okay, updated to 9.1…problem confirmed. This isn’t going to be easy, so hang tight. I’ve already got a set of releases I’m trying to get out the door, so this is going on the pile as “next” on the to-do list. Can’t do it right away. Logic will run in 32-bit mode, so I suggest that’s your workaround for the moment.

We will try to make 64-bit capable builds, though…so I’m not saying we won’t do it. Just a matter of number of people * number of hours in the day.


Hi Scott,

No problem - I understand Apple usually springs these updates on developers who are then faced the task of updating their software while the DAW update is already “in the wild” so to speak!

I am using Logic in 32bit mode still as there are a few other plugin’s I use on a daily basis that are not compatible yet either. Thanks for the fast reply and update!

Kind Regards



Not sure if this is related, but within Logic 9 any instances of the Rocket that are on tracks that were once frozen and then unfrozen for further editing, cause Logic to lose its audio and all you get are pops and clicks. I had been trying to reset the audio device (in this case a Presonus FireStudio+DigiMax FS), and then Logic would roll along fine until the playhead hit any of the regions on those frozen/unfrozen tracks. Then the audio would drop out again and I’d get those pops and clicks. I ended up going on a plug-in witch hunt and found out that I could temporarily fix the problem by removing/replacing the instances of the Rocket. That seems to work until I either freeze or unfreeze the track again. But once I figured all of that out I have tried testing it over and over again and it is doing this every time. Doesn’t matter what latency settings are used or what other plugs might be on the same affected track. Pretty consistent.

My specs are 10.5.8 on a MacBook Pro 2.4 Core2Duo with 4 GB of ram. Latest Logic 9 build. Presonus drivers are latest.

Still need to buy the Rocket. Bought all the others except the Reverb and BadBuss (those are on my list too). That being said I’m constantly talking up your plugs to friends. Worth every cent…

Good luck on the bug fixes! Let me know if you need someone to help test the new builds in Logic. Will be using Snow Leopard as soon as my band’s current song project is finished up. Looking forward to it…


Make sure you try the latest betas and see if that resolves the issue…there were some fixes made within the past week or so that have to do with resets when the plugin passes in and out of active state that may help.

Glad you’re digging 'em.


Will do. What you just described fits the bill. Will check out the betas.

Thanks again!


Well I dropped in the Rocket Beta AU and re-instantiated all of the instances in my current mixdown project. So far so good. Logic hasn’t choked up yet. Will post accordingly… :slight_smile:



Uhhh…wait, I just noticed…you’re running in 64-bit mode and not having problems? Cooool…I had some issues with that earlier.