Rocket makes whole song silent

G5 dual 2ghz / OSX 10.4.11 / Logic 7.1.1

LOVE the plugz!!!
But Rocket makes the whole song silent. It makes the output go to FULL volume with a click sound but no sound comes out. (Yes… pinned meters, with NO sound)

I’ve had this problem with Colortone and a few other plugz in the past. Any idea how to fix it?


On Logic 7…not sure. It works in Logic 8. I’m headed out of town for the next two days on business, but if you’ll be around this weekend, I’ll try to post a build that will create a trace log that you can send me to help diagnose where the problem is.

I’d help faster if I could…


Thanks Scott!

Actually, it doesn’t ALWAYS make the song silent… just sometimes. And if I remove the problematic plug and replace it with the same plug, the problem is solved.

Have to agree, AMAZING product!

I do however have a similar problem. I’m running Protools HD 7.31 on OSX 10.4.11(plugs obviously wrapped) and whenever i return to a saved project most of the channels containing either a rocket or 1973eq is pinned to full volume and i have to resort to workaround as described by bump music. Not a train smash, but it a bit inconvenient if i have to do this on 20+ tracks!

Thanks for your time!


Well, looks like the plan for the next few days is:

  1. get the wrapped plugs to WORK on my PT7.4 system (sorry mates…no PTHD here, just PTMP) so I can test. Still working with FXpansion on this one.

  2. go buy a copy of Logic Express and hope the same problem manifests, so I can find it.

I’m having the same issue here in Logic 8.
It happens just about every time I call up a session with the plug ins. I usually have to launch the plug, save the preset, then reinstate it and recall the preset.
I’ve had this happen with other plug ins in the past, so it’s not completely out of the ordinary.
Hopefully it’s a simple fix because I can’t stop using this plug on pretty much everything I do!

I also got it on Cubase 4.5. Seems that the plugin suddenly stops outputing untill you remove and add it again. I was testing with 16 tracks for an hour and it only happened once.

Just downloaded the Rocket update (performer sidechain fix).

At first it looked promising. In the tests I’ve run so far, it seems to load a session now without immediately introducing the pop and silence glitch.
But once Rocket is copied onto another channel, I still get the immediate pop and silence again.

It also seems that the plug isn’t remembering previously saved settings. It comes up with all settings zeroed in the few sessions I’ve tested.

Another possibly related anomaly is that once I get the pop/silence, it renders my SSL Duende firewire plug ins useless. Nothing brings them back except a full shut down and restart of the computer. If I try to load one I get a “failed to load plug in” alert.

Man, that’s weird. There shouldn’t be ANYTHING that could cause that. Of course, I’ve been wrong before and probably will again.

re: losing settings…are you creating a project on a PPC mac and then moving to Intel mac or vice-versa? number and type of parameters hasn’t changed, and all other hosts, PC and Mac, don’t have a problem there. Moving from one processor type to another is the only thing I currently know of that will do that, and we’re in the process of finding a fix. That would apply to ALL of our plugins, not just Rocket.


I’ve used an intel machine for the testing and haven’t switched to anything else.
And I’ve tested it with about 4 different sessions and the result is the same… and I’m no longer able to call up the presets that I created. Only the factory presets work, mine do nothing when selected. There is a chance that this is the reason they’re not recalling from previous sessions. I’m not sure if I used any of the factory presets.

Definitely seeing less pop/silence so far though. Unless I copy/paste.
I’m going to do more testing tonight.

and as far as the Duende goes, well, that has never been the most stable unit in my studio.

ok… I’ve tested a bunch more. It’s definitely feeling solid now.

I think now the only issue I had was my saved presets from the previous version not working.
Otherwise, I’m not getting pop/silence with general launching and plug in inserting, and I’ve saved a bunch of presets now and everything is relaunching perfectly.

I’d love to hear if anyone else is having the same success.


I just downloaded and tested the latest version of Rocket, 1973 and Bad Buss Mojo. None of them will load previously saved presets.

I tested AudioUnit versions on both a PPC Mac and an Intel Mac, each of which I had previously saved presets which worked in the previous version of the plugins.

I’m running Logic 8.0.2 on a Core2Duo 2.16GHz MacBook Pro with OS X 10.5.4 and a Dual 2.0 GHz G5 PowerMac with 10.5.3.



I want to be clear here…will previously saved projects still have their settings in them, or is it just that user presets that you’ve created have a problem.

secondly, if it’s just the presets that have the problem, is it that the presets don’t show up, or that they don’t show values when you select them?

lastly, is this just for AU plugs, or have any of you tried the OS X VST versions?


EDIT I think something crept into the code that shouldn’t have been there. Fixed. Please re-download and let me know if the problem has gone away.

EDIT AGAIN Confirmed that project settings are retained with latest, latest version (~0550 GMT 24 Sept 08)


Hi Scott,

The 24 Sept 08 versions fix the problem I was seeing.

The problem was that when I selected a preset that I had made with a previous version nothing would change. The preset name did not show up in the GUI nor did any of the controls change. Also, when loading a project that was saved with settings the plugins would come up with all controls at their default values. I only tested them on the AU versions.

Both those issues are fixed in the latest versions.



the latest build (sept 28 12:45am) brings back the pop/silence as soon as I launch a session.

I went back to the build from yesterday (sept 27th 5:15) and it still seems to work perfectly for me. I’ve gone back to that one.

Welcome, time traveller! I’ll now be sure to not make the mistake that will cause that error…the universe will probably implode, but anything in the name of progress…



PS: Today is the 24th of September…

haha… oops!

At least you’ve got 4 days to work on it before it happens! :wink:

I meant 24th/23rd.

More seriously…make sure that the latest (broken) version you have is the latest version on the website…I’m going to GC today to go buy a copy of Logic Express…gonna nail this down.


I downloaded again to be sure and it’s definitely the latest version.
Neither that one, or the previous are really working properly on my system yet.
Still having lots of pop/silence issues.
Curious to see if you’ll be able to replicate the issue on your system.
It definitely takes more than just 1 track with the plug to make it pop. I’ve got a few instances of it loaded into 3 different sessions I’m currently working on.
If I can get it to launch w/o popping, it will usually stay functioning w/o any problems.
But as soon as I switch b/t sessions or quit/relaunch, I almost always get it.

I’ve got a copy now…we’ll see what I can find out.