cmx bundle has no dmg file to install

hey guys. stillwell don’t feel like helping me out on this one so in hope, i turn to you-

i dloaded cmx au bundle and tried to install it on my mac but no go- there's no dmg file to install. when i click on what looks like the only possible install file in the bundle, nothing happens. am i missing something here?

i run osx 10.5 and logic 7.2 will cmx work within these programs? if yes, can anyone please give me any tips on how to get it up and running?

i bought it well over a week ago now and have sent a few tickets to stillwell support but with no reply whatsoever,

help!!     thanks in advance

also, the link that i got emailed to me with the key file for cmx, comes up when clicked on but has no option to dload any key file-says ‘not available’ .

  i'm utterly stumped. how can this be so hard compared to installing rocket and bombardier?... which i managed perfectly easily

This has been resolved via email.

Folks, when you purchase a plugin, the key file links expire a week after purchase…grab 'em while they’re hot. If something prevents you from doing so before the link expires, open a support ticket and supply us with the original order number. But please, try to download the keyfile BEFORE the link expires.